瀚海星空

星空浩瀚 人类渺小

在mac osx上安装机器学习开发环境

概述 上一篇“在linux上安装机器学习开发环境”文章演示了在centos下设置机器学习环境. 本篇讨论如何在mac下配置相关环境. 下载Anaconda Anaconda介绍在上篇中有, 在此不再重复. Anaconda 安装包可以到 https://mirrors.tuna.tsinghua.edu.cn/anaconda/archive/ 下载。 我下载的是4.3.1 zhh@z...

在linux上安装机器学习开发环境

下载Anoconda Anaconda 是一个用于科学计算的 Python 发行版,支持 Linux, Mac, Windows, 包含了众多流行的科学计算、数据分析的 Python 包。 Anaconda 具有比pip包管理更强大的能力,不仅管理python 包的依赖,也同时管理其他非python的依赖,所以有逐渐取代pip的趋势. 同时, Anaconda还有virtual envi...

Centos安装升级python3.6

安装流程 安装python3.6可能使用的依赖 下载解压安装包 编译安装 [zhouhh@mainServer ~]$ cat /etc/redhat-release CentOS Linux release 7.1.1503 (Core) [zhouhh@mainServer ~]$ sudo yum install openssl-devel bzip2-devel e...

keras linux安装

Keras 是古希腊语中”角”的意思, 最早出现在古希腊的《奥德赛》. 梦神被分为两派. 一派用虚假景象欺骗人们,他们通过象牙之门来到地面. 一派启示即将经历的未来, 他们通过角之门来到地面. Keras刚开始是开放终端神经电子智能机器人操作系统ONEIROS (Open-ended Neuro-Electronic Intelligent Robot Operating System)项...

PCA的数学原理【转】

PCA的数学原理 作者 张洋 | 发布于 2013-06-22 机器学习 线性代数 PCA PCA(Principal Component Analysis)是一种常用的数据分析方法。PCA通过线性变换将原始数据变换为一组各维度线性无关的表示,可用于提取数据的主要特征分量,常用于高维数据的降维。网上关于PCA的文章有很多,但是大多数只描述了PCA的分析过程,而没有讲述其中的原理。这篇文章的...

模式识别和机器学习读书笔记1

1.1 曲线拟合 用下式来拟合数据. 其中M是多项式的阶数(order),$x^j$表⽰x的j次幂。多项式系数$w_0…w_M$整体记作向量w。 注意,虽然多项式函数$y(x,w)$是x的⼀个⾮线性函数,它是系数w的⼀个线性函数。类似多项式 函数的这种关于未知参数满⾜线性关系的函数有着重要的性质,被叫做线性模型 过拟合 当我们达到更⾼阶的多项式(M = 9),我们得到了对于训练数...

书籍标题中章节号js正则去除

书籍标题中章节号js正则去除 周海汉 http://abloz.com 2017.3.4 书籍中的章节, 经常会有序号. 但有时需要在前端展示时将其隐去. 如”第一篇 开天辟地”, 执行后只剩下”开天辟地” 本文主要是用js在前端隐藏序号, 避免直接编辑源文件. 来源:http://abloz.com 章节序号有如下千奇百怪的形式: 第一篇 第一章 ...

python爬虫图片抓取失败和乱码问题

图片下载失败 网址:http://news.xinhuanet.com/politics/2017-03/01/c_1120551648.htm curl http://news.xinhuanet.com/politics/2017-03/01/1120551648_14883580941071n.gif -o c.gif curl --head http://news.xinhuan...

pymysql 解决utf8mb4扩展

问题 在将一些emoji表情符号入库时, 发现utf8的表插入会失败. mysql5.6以上支持utf8mb4的扩展, 必须配置相应的扩展, 并且客户端python程序采用最新的pymysql,设置charset=’utf8mb4’才可以正确插入. 采用MySqlDB则不能解决该中文乱码问题. 创建库的缺省编码指定utf8mb4 CREATE DATABASE `data_v1` DEFAU...

从wordpress移植到Jekyll!

安装 jekyll sudo gem install jekyll ➜ ~ jekyll –version jekyll 3.4.0 安装 bundler. 它是管理其他gem兼容性的. ➜ ~ sudo gem install bundler ERROR: While executing gem … (Errno::EPERM) Operation not permitt...